Deployment instruction

Topics: Developer Forum
Oct 27, 2006 at 3:12 PM
Dear all,

Is it possible for you to give me some simple instructions on how to deploy the starter kit? I wish to show the site plus some of my own mod to the customer before the deadline...

Thanks guy.
Oct 27, 2006 at 4:04 PM
Hi all,

figured it out and it was quite simple...

But now, how come the Default.aspx is blank when run from the IIS but not so when run from Visual Studio?
Oct 28, 2006 at 9:41 AM
Hi!

Maybe because you are using built in VisualStudio web server (Cassini)?


Btw. This forum is dead - there is no answer from authors ;(

Kind regards
Mateusz
Oct 28, 2006 at 1:48 PM
Hi kierepka,

Thank you for your info... I'm using IIS. For some reason the welcome box does not show up... On contrary, the welcome box shows up when I run the project from Visual Studio... I really don't know why that's the case...

So there is no support for this starter kit?
Oct 28, 2006 at 3:57 PM
Hey,

Just worked out why the default.aspx page was blank when run under IIS... it is because I didn't set any control to be visible under an administrative account. You should do that first time when the site is run.

Nov 4, 2006 at 1:15 PM
Ok - I give a TBH some time, but as far as I can see this project is dead and there is no support for it. I will move my XNA.pl web site to Umbraco (http://www.codeplex.com/Wiki/View.aspx?ProjectName=umbraco). This is sad but I think this is only one solution right now for me.
Nov 19, 2006 at 7:54 PM
Hello... I see the WelcomeBox where the content shows up when I run the site from visual studio. However the center zone is blank or empty if I run it from IIS? What did you do to have the default content NOT be blank when you run from IIS?

Thanks!
Nov 19, 2006 at 8:41 PM
Okay, I now see what you were saying... You have to LOG IN as an administrator, then make sure you Switch the curren scope to =shared. and then choose the "catalogue view and check off the controls you want to see in the default.aspx page.

What I don't know is what is checking those boxes changing? Is it something in the database?

Thanks!
Apr 6, 2007 at 4:07 PM
Hello All,

I'm a college student trying to build an E-commerce website. I downloaded The Beer House starter kit but I'm not sure how to run it. I have already installed Visual Web Developer 2005 Express Edition on my PC but I still cant manage to run the starter kit. It says that i need to install the TBHDeploy , TBHSetup and TBHCustomEvents but I'm not sure how to install it. Can any kind person help me out here please?
Thanx=)
Apr 6, 2007 at 4:13 PM
Hi again,
I've been reading the ReadMe file and it says something about copying the .mdf and .ldf that are distributed with the code. I can't seem to find the file either. Please help me..any kind soul out there..I'm kinda freaking out now=( I'm totally new in ASP.Net...I hope guys don't mind if all these questions sound stupid or lame..=/
Thanx again..=)
May 17, 2007 at 6:53 PM
Edited May 17, 2007 at 7:18 PM
How do you deploy this??? I want to use the VB version but I needed to download the c# version for the installation instructions, which seem to be leaving something out. The only database I see is the aspnet.db database, is this the one I am supposed to rename to TheBeerHouse.mdb and attach to sql server 2005? Also, when opening the project I get errors that "TheBeerHouse_deploy.wdproj is not installed"...

How the heck do I get this thing running???

Thanks!