Does anyone have a complete functioning version of this?

Topics: Developer Forum, User Forum
Mar 24, 2010 at 7:22 PM
Edited Mar 26, 2010 at 8:09 PM

I have ordered the book, should be here tomorrow, and maybe it will clear everything up?

But there appear to be a large number of more and less critical bugs.

Items do not get added to the shopping cart.

Login dialog is invisible or ugly in IE8.

Articles do not end up on the page in thir designated place. There are probably a lot more.

If it worked it would be a great starting point. But it is beginning to look like all hat, no cattle.

Kal

I should have been more clear about the version. When I wrote this I had only Source Code BeerHouse-C-3.5.zip It compiled but was as described.

Later I downloaded 2.0 Production - MVC May 18 2009, Stable, and that works as far as I tested it, but is kind of feature poor.

Later still I downloaded the source code Latest Version and it did not even compile. I tried to update it with https://TheBeerHouse.svn.codeplex.com/svn but it blows up in the App_Theme directory. I eventually got it to compile but most of the bugs remain.

This 3.5 Webforms version is a pretty sorry example of an application. If you need help, you might look here: http://aspadvice.com/blogs/net_discoveries/archive/2010/03/19/Filling-in-the-Gaps-_2D00_-Problem-Design-Solution-3.5-_2D00_-Part-2.aspx?CommentPosted=true#commentmessage -

I bought the MVC book and it mostly works so may build something around that.

Coordinator
Mar 27, 2010 at 4:02 PM

The IE8 login dialog issue I am aware of, and I cannot for the life of me figure out what is going on. It was working just fine when I completed the book 15 months ago. Sometime around mid-June as far as I can tell it just stopped working. Stepping through in the IE developer tools everything executes as expected, etc. I may post a jQuery version on my Blog soon, but since the publisher wanted ASP.NET AJAX in the book, well...

As far as your Themes issue, I am not sure what that might be, you did not include any specifics to the issue.

A working version of the code that is available to download from CodePlex is running, http://beerhouse.extremewebworks.com/ If I update the code, I update the site to reflect the code change.

Mar 28, 2010 at 4:51 AM

Well, so far the two things there I have tried on your extremwebworks.com have blown up:

When I tried to register to place an order:

http://beerhouse.extremewebworks.com/Error.aspx?aspxerrorpath=/Register.aspx

I clicked on an article:

http://beerhouse.extremewebworks.com/article-special-irish-concert---free

A few more work as far as I pushed them, which was not very far.

Site map is empty.

None of the Article Categories appear to work.

 

Mar 30, 2010 at 11:48 PM

This is my first exposure to Entity Framework so maybe you can clear something up for me. In the svn source code version (possibly others, I have not checked) none of the many stored procedures appears to be included in the related .edmx file. If this is not "by design" it might explain why so many things do not work.