Application is too slow

Topics: Developer Forum, Project Management Forum, User Forum
Sep 16, 2009 at 4:04 PM

Hello all,

I have a problem and I would like to ask a question about it. I have read the book "ASP.NET MVC 1.0 Website Programming" and I have developed the TheBeerHouse example application. My computer is fast and runs without problems but TheBeerHouse application (with debug mode disabled) is very very slow. I thought it was the first time I enter a page, but the reality is that whenever I enter pages (whatever) everything is going very slowly. Please, could anyone help me?

Many thanks,

Best regards

Coordinator
Sep 16, 2009 at 5:05 PM

Most of what you are talking about is relative.  Can you be more specific?

Sep 16, 2009 at 5:17 PM

I mean that when I start the application deployed on IIS7 it takes a long time to load every page, even on my local server. However, other applications deployed on my server and developed with ASP.NET 3.5 works perfectly. I do not know why this happens.

Many thanks

Coordinator
Sep 16, 2009 at 6:11 PM

Where is the database located?

Sep 16, 2009 at 6:13 PM

It is a Sql Server 2008 Express data server located on my computer too. It seems very strange

Coordinator
Sep 16, 2009 at 7:10 PM

I don't know then, haven't heard of anybody else having issues:

  • Maybe you are running too much on your machine.
  • Maybe you have a virus.
  • Maybe your machine isn't as fast as you think it is.
  • Maybe your expectations of MVC are out of whack with reality.

There are too many maybes and you haven't been able to give me any solid numbers, so I really don't know what I can tell you.  Other than try to duplicate the issue on another machine.

Sep 16, 2009 at 7:18 PM

Ok, I will continue searching what happens to my application. If I find out it I'll let you know.

best regards